Citrix Down
Incident Report for Ember IT
Resolved
All Citrix systems are up and running at this time. Thank you for your patience. We'll sound out further details about what the issue was shortly.

Matt @ Ember IT, CTO.
Posted 3 months ago. Apr 08, 2019 - 12:46 EDT
Update
Customers are beginning to come back online. We will reach out when each connection is restored.

thank you.
Posted 3 months ago. Apr 08, 2019 - 11:36 EDT
Update
We're continuing to work on the Citrix issue. We expect to have an update in the next hour. Thank you.
Posted 3 months ago. Apr 08, 2019 - 09:30 EDT
Identified
Users are experiencing issues connecting to Citrix. We've identified the issue and are working to resolve.
Posted 3 months ago. Apr 08, 2019 - 08:28 EDT
This incident affected: Valley Forge Datacenter.