Client Ticketing Portal Outage

Incident Report for EMBER HELP DESK

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 11:15 EDT

Investigating

We are currently investigating an issue impacting the ticketing portal. Users may be unable to access the portal or submit/view tickets at this time. Our team is actively working to identify the root cause and restore service as quickly as possible. We will provide updates as more information becomes available.
Posted Apr 24, 2026 - 10:52 EDT
This incident affected: Service Desk - Ticket Portal.