Ticket Portal Outage
Incident Report for Ember IT
Resolved
Ticket.emberit.com is back online. Some customers may not be able to reach the site for another hour due to DNS changes that had to be made.

Thank you.
Posted almost 2 years ago. Aug 16, 2017 - 16:19 EDT
Investigating
Our ticket portal ticket.emberit.com appears to be offline. We are working with our partner to find out the status of this page. In the meantime you can call our support desk or email support@emberit.com.

Thank you.
Posted almost 2 years ago. Aug 16, 2017 - 15:15 EDT