National Comcast Outage
Incident Report for Ember IT
Resolved
This incident has been resolved.
Posted over 1 year ago. Jul 02, 2018 - 07:55 EDT
Monitoring
All Ember IT Services are up and running, however Comcast is experiencing a national outage. This could affect your phones and Internet connectivity in your office.

http://downdetector.com/status/comcast-xfinity/map/
Posted over 1 year ago. Jun 29, 2018 - 14:07 EDT