Ticket.EmberIT.Com Down
Incident Report for Ember IT
Resolved
Ticket system access has been restored.
Posted about 1 year ago. Oct 11, 2018 - 14:41 EDT
Investigating
ticket.emberit.com is currently down. We are investigating with our partner to find out the status. We will keep you up to date as we learn more. In the meantime please utilize our helpdesk via phone: 610.409.9555.
Posted about 1 year ago. Oct 11, 2018 - 13:47 EDT
This incident affected: Helpdesk - Ticketing System.