Support Portal Offline
Incident Report for EMBER HELP DESK
Resolved
Amazon AWS issue has been resolved. EMBER Ticket portal and email support is now fully operational. Please utilize the ticket portal for support requests. Thank you.
Posted Dec 08, 2021 - 07:15 EST
Identified
EMBER's support portal is still experiencing outages, along with our email support system, help@emberit.com. This is due to the larger AWS outage affecting services from Amazon, Disney+, Ring, Alexa, and others. Please use our phone for support. 866-EMBER-IT.

https://www.theverge.com/2021/12/7/22822332/amazon-server-aws-down-disney-plus-ring-outage
Posted Dec 07, 2021 - 16:02 EST
Investigating
EMBER's partner, ConnectWise has confirmed they are experiencing an outage with our ticketing system. For now, please contact our support desk directly if you need assistance: 866-EMBER-IT. Updates to follow. Thank you.
Posted Dec 07, 2021 - 13:32 EST
This incident affected: Service Desk - Ticketing System.