Phone Outtage
Incident Report for Ember IT
Resolved
Phones have been restored. This was a short, nationwide Windstream outage that's now resolved. Thank you for your patience.

Matt Toto, CTO
Posted 7 months ago. Mar 04, 2019 - 15:39 EST
Investigating
Ember IT is experiencing a phone outage. We are waiting to for more information from our carrier. In the meantime to put in a ticket, please utilize our ticket portal at http://ticket.emberit.com. Ember IT techs will contact you back via cell phones until the system is back up.

Thank you.
-Matt Toto, CTO
Posted 7 months ago. Mar 04, 2019 - 14:19 EST
This incident affected: Helpdesk - Phone Support.