Phones are down
Incident Report for Ember IT
Resolved
Our main number is correctly routing to our phone system. Thank you for your patience while we worked with our phone vendor to get this resolved.

Matt @ Ember IT
Posted 2 months ago. Jun 10, 2019 - 15:41 EDT
Update
Our main number is not currently routing correctly (610.409.9555). However we're able to dial out and return calls. Again please utilize the ticket portal to initiate a support request and we'll get back to you as quickly as possible.

Thank you.

Matt @ Ember IT
Posted 2 months ago. Jun 10, 2019 - 11:01 EDT
Identified
Ember IT is experiencing a phone system outage. We are working with the vendor on an ETA. Please utilize the ticket portal ticket.emberit.com to initiate a support case. We will be able to return your call.

Thank you. Matt @ Ember IT
Posted 2 months ago. Jun 10, 2019 - 09:21 EDT
This incident affected: Helpdesk - Phone Support.