Office 365 Delays
Incident Report for EMBER HELP DESK
Resolved
Microsoft is reporting this issue resolved.
Posted Jun 09, 2017 - 05:56 EDT
Monitoring
This is a quick courtesy message to let customers know that Microsoft Office 365 is experienceing email delays of up to 2 hours sending and receiving emails. If this is still occurring Friday morning we'll send out another notice. No Ember IT services are effected.

Thank you.
Posted Jun 08, 2017 - 21:04 EDT