Ticket Portal: help.emberit.com is down
Incident Report for EMBER HELP DESK
Resolved
Systems appear to be up and running at this time. Connectwise considers this resolved. Thank you for your patience. Please resume using help.emberit.com for your support needs.

-EMBER
Posted Nov 25, 2020 - 15:49 EST
Update
This outage has been tied back to a larger, global issue happening at Amazon AWS. Their East-US datacenter is experiencing issues affecting hundreds of different cloud-based systems. Please continue to use our email help@emberit.com for now.

Thank you.

-EMBER
Posted Nov 25, 2020 - 12:51 EST
Identified
We have confirmed that our partner, Connectwise, is experiencing an outage which is affecting our ticket portal. Please utilize the email help@emberit.com to create a ticket until this is resolved.

Thank you

-EMBER
Posted Nov 25, 2020 - 09:55 EST
This incident affected: Service Desk - Ticketing System.