Office 365 Intermittent Issues
Incident Report for EMBER HELP DESK
Resolved
Microsoft considers this issue resolved. Some users may still experience issues until Thursday, when their patch finishes rolling out.

Thank you.

Matt Toto
Posted Aug 19, 2020 - 09:12 EDT
Identified
Microsoft has notified us that Office 365 is having some intermittent issues with Outlook, Outlook Web Access and the web portal. Ember IT technicians are having trouble connecting to the Admin Portal to make changes on behalf of our clients. Outlook may delay sending emails out. We will update again once we know more.

Thank you.

Matt Toto
Posted Aug 18, 2020 - 13:43 EDT
This incident affected: Service Desk - Phone Support.