Phone System

Incident Report for EMBER HELP DESK

Resolved

This incident has been resolved.
Posted Nov 05, 2020 - 22:54 EST

Investigating

We've received a couple reports of calls to our help desk being dropped. We are investigating the issue.
Posted Nov 05, 2020 - 10:49 EST
This incident affected: Service Desk - Phone Support.