Incident has been resolved. The service portal is fully operational.
Posted Oct 30, 2025 - 09:20 EDT
Identified
Microsoft has identified an issue impacting Azure services, which is currently preventing access to our client portal (help.emberit.com). Microsoft is actively mitigating the problem, but the portal remains unavailable at this time.
There is currently no estimated time for full restoration. We’ll continue monitoring Microsoft’s updates and will update again once access is restored or a resolution timeframe is provided.
If you need assistance during this time, please submit requests by emailing help@emberit.com. Clients with chat access can also reach us through the EMBER chat icon in Teams, if available.
Posted Oct 29, 2025 - 14:58 EDT
Investigating
We are currently monitoring the issue.
Posted Oct 29, 2025 - 12:07 EDT
This incident affected: Service Desk - Ticket Portal.