Barracuda Email Delivery
Incident Report for Ember IT
Resolved
This incident has been resolved.
Posted almost 3 years ago. Nov 18, 2016 - 09:57 EST
Monitoring
Email is flowing again and the existing queue is emptying. No email was lost. We're still trying to determine what caused this. Nothing changed on Ember IT's side but we are noticing a huge, country-wide Level 3 outage that's more than likely the culprit. We're still reviewing.
Posted almost 3 years ago. Nov 17, 2016 - 16:41 EST
Investigating
Ember IT is currently investigating an issue with email delivery for customers utilizing our Barracuda SPAM filtering appliances. Email may be delayed.
Posted almost 3 years ago. Nov 17, 2016 - 16:06 EST