Office 365 Outage
Incident Report for EMBER HELP DESK
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 13:03 EDT
Monitoring
Microsoft is reverting an update they made that caused the outage. Services are slowly being restored now. We'll continue monitoring the situation overnight.

https://status.office365.com/

Thank you.

Matt Toto
Ember IT
Posted Sep 28, 2020 - 20:15 EDT
Identified
Microsoft has confirmed an outage with Microsoft Office 365. This includes Teams and Email. Please follow the status here: https://status.office365.com/

We will update when we confirm they've restored services.
Posted Sep 28, 2020 - 18:55 EDT
This incident affected: Microsoft 365 Services.