Phone outage
Incident Report for EMBER HELP DESK
Resolved
This incident has been resolved.
Posted Feb 19, 2019 - 16:08 EST
Update
Phones are back up!
Posted Feb 19, 2019 - 16:07 EST
Investigating
Our phones appear to be offline. We're waiting to hear back from support on the status. Please use our ticket portal @ ticket.emberit.com to put in a new support request.

Thank you.

Matt Toto, CTO
Posted Feb 19, 2019 - 15:31 EST
This incident affected: Service Desk - Phone Support.