Teams Meetings - Outage
Incident Report for EMBER HELP DESK
Resolved
While this issue is still going on, Microsoft is reporting it's simply due to a spike in traffic. We're closing this case, but be aware you may still experience a hiccup or two while attempting to log into a Teams Meeting.

Thank you.

Matt Toto
Posted Aug 20, 2020 - 10:20 EDT
Identified
Microsoft has identified an issue with Microsoft Teams in which users are not able to join a meeting. Next update is expected in a few hours. We will notify with additional info when we have it.

Thank you.

Matt Toto
Posted Aug 19, 2020 - 13:15 EDT
This incident affected: Microsoft 365 Services.