Global MS Teams Outage
Incident Report for EMBER HELP DESK
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 09:16 EDT
Identified
Update from Microsoft: "We’ve identified the root cause and performed mitigation actions. We’re seeing signs of recovery and will continue to monitor the service. Users still experiencing impact should restart their clients to expedite recovery. "
Posted Apr 27, 2021 - 08:54 EDT
Investigating
Microsoft has confirmed a global issue with Microsoft Teams services. You may experience issues logging into the app or using the website. We will update again when additional information is available.

Thank you.

Matt @ EMBER
Posted Apr 27, 2021 - 08:25 EDT
This incident affected: Microsoft 365 Services.