Phone Number Offline
Incident Report for EMBER HELP DESK
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 13:50 EDT
Investigating
Our main number (610.409.9555) is currently offline. Please utilize our 866 number for phone support (866-EMBERIT). All other methods are fully operational.
Posted Sep 16, 2022 - 11:26 EDT
This incident affected: Service Desk - Phone Support.