Inbound Email Delivery - Degraded Performance
Incident Report for Ember IT
Resolved
Barracuda has resolved the issue with their Cloud Filtering service.
Posted over 2 years ago. Nov 03, 2016 - 12:10 EDT
Identified
Per barracuda.statuspage.io :

Identified - Some customers using the Barracuda Essentials for Email Security solution are experiencing delays in incoming email delivery, accessing the message log and end user quarantine interfaces. Other parts of the administrative user interface are fully accessible. We are actively working on the problem. Our initial investigations revealed an unusually high volume of inbound connections from multiple unverified source IPs. We are in the process of sanitizing this traffic. As a result, the quality of service is gradually improving.
Posted over 2 years ago. Nov 02, 2016 - 15:32 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 2 years ago. Nov 02, 2016 - 15:31 EDT
Identified
Barracuda is reporting a degraded performance with their inbound delivery service. Barracuda states that "Engineering and Operations teams are still working to resolve delays in mail delivery". At this time there is no estimated time for a resolution. Outbound messaging is unaffected. Because of this you may experience delays in receiving email. This can currently be monitored at http://barracuda.statuspage.io
Posted over 2 years ago. Nov 02, 2016 - 14:38 EDT