Ticketing System Outage

Incident Report for EMBER HELP DESK

Resolved

The issue impacting our ticketing system appears to be resolved at this time. We will continue to monitor for stability, but you may resume using the system as normal. If you experience any further issues, please contact us at 1-866-EMBER-IT.
Posted Apr 20, 2026 - 13:35 EDT

Investigating

We are currently investigating reports of an outage affecting our ticketing system. In the meantime, for technical support, please contact us by phone at 1-866-EMBER-IT until the issue is resolved.
Posted Apr 20, 2026 - 11:33 EDT
This incident affected: Service Desk - Ticketing System and Service Desk - Ticket Portal.